It is currently Tue Aug 22, 2017 2:56 am

All times are UTC + 10 hours [ DST ]




Post new topic Reply to topic  [ 12 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: finally got the pants v1 drive...
PostPosted: Thu Dec 05, 2013 1:21 am 
Offline
AWRTGUMA Newbie

Joined: Tue Jan 01, 2013 9:26 pm
Posts: 19
and i have been struggling to make it work all this week. So today i started from scratch.
Formatted my HDD, installed a fresh copy of windows xp.
Partitioned the drive, i now have c: and x:
copied all hyperspin files to the root directory in x:

when i run hyperspin it loads but if i try to select an emulator (mame, sega etc) whenever i press enter it just returns to the main menu.

Is there some other software i need to install on the pc? I did find a thread stating that i need to install daemon tools but it would appear its not on the drive.

Is directx required?

thanks guys


Top
 Profile  
 
 Post subject: Re: finally got the pants v1 drive...
PostPosted: Thu Dec 05, 2013 12:59 pm 
Offline
Founding Board Member

Joined: Mon Sep 27, 2010 9:14 am
Posts: 75
mmh, dash would be the guy here, but BGH would ne able to help. I'm not at the computer with my hyperspin setup on it so I can't check. I presume you would need directX installed, just because everything uses directX these days. I don't have deamon tools running, but I do have VirtualCloneDrive as the optical drive emulator. VCD is free from it's website(slysoft I think).

I presume that some of the paths are screwed up in a configuration setting somewhere.


Top
 Profile  
 
 Post subject: Re: finally got the pants v1 drive...
PostPosted: Thu Dec 05, 2013 1:04 pm 
Offline
Founding Board Member | Admin
User avatar

Joined: Sat Sep 25, 2010 4:04 pm
Posts: 2339
Location: The 80s baby!
It's been a while since I set mine up but now I think about it I think you'll need to go into each emulator outside of Hyperspin and make sure the paths are all set up correctly. So just launch the MAME exe etc and check your paths, some will not exist but the ones you need will be there, ROMs, art etc.

I think what's happening at present is Hyperspin is sending the instruction to launch but is not getting a response from the respective emulators.

Also double check your paths to the executables are correct in HyperHQ.

If you still have dramas I'll have a look at my settings tonight for you.

_________________

"If I can't build a time machine then I'll build machines from back in time." - Me

A.W.R.T.G.U.M.A Sisterhood
Founding Member


Top
 Profile  
 
 Post subject: Re: finally got the pants v1 drive...
PostPosted: Thu Dec 05, 2013 1:59 pm 
Offline
AWRTGUMA Newbie

Joined: Tue Jan 01, 2013 9:26 pm
Posts: 19
i think im finally getting somewhere - i had to install .net framework and also a couple of the paths were incorrect

Im finally playing games... but windows keeps popping up with a message from 'sticky keys'
i checked in control panel and its not even enabled, how do i stop this?


Top
 Profile  
 
 Post subject: Re: finally got the pants v1 drive...
PostPosted: Thu Dec 05, 2013 2:48 pm 
Offline
Founding Board Member | Admin
User avatar

Joined: Sat Sep 25, 2010 4:04 pm
Posts: 2339
Location: The 80s baby!
Ah good old sticky keys :(

Here's a good link to get rid of them...

http://www.techrepublic.com/blog/window ... n-windows/

Nothing worse than playing a really good game and then BAM! Sticky keys, grrr!

_________________

"If I can't build a time machine then I'll build machines from back in time." - Me

A.W.R.T.G.U.M.A Sisterhood
Founding Member


Top
 Profile  
 
 Post subject: Re: finally got the pants v1 drive...
PostPosted: Thu Dec 05, 2013 2:54 pm 
Offline
AWRTGUMA Newbie

Joined: Tue Jan 01, 2013 9:26 pm
Posts: 19
thanks mate! getting exciting now :)

I still find that hyperspin isnt very responsive sometimes, for example you press start , to start a game, and you have to press it 5 or so times before it starts - ill check the settings,

right now im just going through all my favourite games trying to set up the controls.

how can i set it up so that when i exit hyperspin, it restarts hyperspin again - rather than going back to windows? Or perhaps there is a way to disable exiting hyperspin ?


Top
 Profile  
 
 Post subject: Re: finally got the pants v1 drive...
PostPosted: Thu Dec 05, 2013 4:46 pm 
Offline
Founding Board Member | Admin
User avatar

Joined: Sat Sep 25, 2010 4:04 pm
Posts: 2339
Location: The 80s baby!
I think to have it restart HS you'd need an AutoHotKey script but it's been so long since I did one I couldn't tell you how sorry. I think there is a setting in Hyper HQ to set the behaviour of the Exit function, mine is set to shut the whole machine down.

I'm not sure why you're HS is being laggy, mine's pretty good, is your Flash all up to date? I believe it's pretty Flash heavy so it may be having a bit of a struggle in the background perhaps? Latest graphic drivers? Mine does occasionally need a second button push, tolerable but yours sounds worse.

With setting your controls up, hit TAB on the keyboard from within any game and you can configure inputs for all games (this is particularly helpful when setting up player 2 buttons 5 & 6 because they aren't mapped to anything by default). This is MAME I'm referring to btw.

Do you have a 2 player cab or 4? I can't remember. I know player 4 controls need to be set up from within MAME (launched independently of HS).

So much to remember! I really should brush up so I can have better recall!

_________________

"If I can't build a time machine then I'll build machines from back in time." - Me

A.W.R.T.G.U.M.A Sisterhood
Founding Member


Top
 Profile  
 
 Post subject: Re: finally got the pants v1 drive...
PostPosted: Thu Dec 05, 2013 7:19 pm 
Offline
AWRTGUMA Newbie

Joined: Tue Jan 01, 2013 9:26 pm
Posts: 19
ive worked it all out - just set the exit command in hyperhq so it doesnt exit back to windows.

im a happy man now :)

I havent managed to set up all the other emulators - only mame,
some very strange things happening there. A lot of the time the splash.exe loads but doesnt dissapear, i can hear the game running in the background but the only way to close splash is to use task manager.

might get it going one day !


Top
 Profile  
 
 Post subject: Re: finally got the pants v1 drive...
PostPosted: Thu Dec 05, 2013 9:48 pm 
Offline
Founding Board Member | Admin
User avatar

Joined: Sat Sep 25, 2010 4:04 pm
Posts: 2339
Location: The 80s baby!
Hmm, sounds like there may be an issue with the MAME exe. I'm pretty sure it's the one I'm running but it might be worth having a look for another version just in case. FYI if you get a later MAME build than the ROM set that's ok, not so great the other way around. Best to try for a version that has save states enabled otherwise you could have issues with saving your NBA Jam progress.

Good to hear you sorted out the exit thing! I remember it took me a long time to get it just right but you will and it will be so worth it!

_________________

"If I can't build a time machine then I'll build machines from back in time." - Me

A.W.R.T.G.U.M.A Sisterhood
Founding Member


Top
 Profile  
 
 Post subject: Re: finally got the pants v1 drive...
PostPosted: Fri Dec 06, 2013 12:35 pm 
Offline
Founding Board Member

Joined: Mon Sep 27, 2010 9:14 am
Posts: 75
Mmh, I don't remember having any of these issues. Mind you, I did remove all the other other emulators and just kept MAME on there..it had enough games :) Never got the double(or 5x) click to start thing, that's something very wrong there. I used AutoHotkey to restart HS if it ever stopped running(through the exit key, or by it crashing etc). I remember stickykeys being an issue, but it's easy to turn off as BGH showed. I was running it through a nice Phenom II cpu for ages, and it was very responsive, less so when I was running on a ION chipset, but was still okay to use. As BGH noted, it might be worth updating some of your drivers too see.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ]  Go to page 1, 2  Next

All times are UTC + 10 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Skin by Lucas Kane
Localized by Maël Soucaze © 2010 phpBB.fr